JavaScript 1.5 or newer is Required For Proper System Operation.